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Introduction
Vectorworks 2010 new features are presented in the following sections.

•	 Improved Modeling 
Usabilit•	 y 
Vectorworks Architec•	 t 
Vectorworks Landma•	 rk 
Vectorworks Spotligh•	 t 
Vectorworks Machine Desig•	 n 
Vectorworks Renderwork•	 s 
Additional Training Materials•	  

Improved Modeling
Vectorworks 2010 introduces dramatic improvements to the 3D modeling environment:

The 2D and 3D evironments are now unified, so you can now easily work in 3D views—across layers—to create, edit,  •	
and visualize you design.
New 3D snapping and drawing interaction enhancements provide more intuitive controls and feedback for accurately  •	
drawing, selecting modifying, and aligning 3D objects, and also for creating or manipulating working planes.
You can now use planar graphics when you need 2D geometry to interact with 3D views.•	
The new Dimensional Constraint Manager (DCM) provides a solid foundation for reliable object associations. Together,  •	
the DCM and interactive dimensions dramatically reduce the need for up-front precision in the design process. You can  
now efficiently develop your designs, starting with an approximate “sketch” and then progressively tightening the accuracy  
using   any combination of dynamic and precise control methods.
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New Unified 2D/3D Environment
Product: Architect, Landmark, Spotlight, Machine Design

The Stack Layers view mode has been renamed to Unified View, and enhanced with new options and improvements for the  
3D modeling environment:

Key new features of Unified View are summarized as follows:
You can now enable the •	 Show Snap Modify Others layer option when Unified View is active.
The new •	 Center View on Activated Layer preference option (off by default) now lets you toggle view shifting  
when you change the active layer.
You can now draw all 2D objects (only on the active layer) when •	 Unified View is active (see also New Planar Graphics).
You can now control page boundary visibility when •	 Unified View is active.
You can now set the Renderworks background for the active layer without having to access the Organization  •	
or Edit Design Layers dialog boxes (menu: View > Set Renderworks Background).
When you change the active layer and •	 Unified View is active, the current view settings are now persistent.
The •	 Set Lighting Options command (menu: View > Lighting > Set Lighting Options) now affects all visible  
layers when Unified View is active.

Animation
Click here to view an animation of these features..

Access
View bar: 	Unified View button  
		  (double-click to set preferences)
Menu: 		 View > Unified View 
		  (or press Ctrl+Alt+L (Windows), 	
		  Cmd+Option+L (Mac))
		  View > Unified View Options 
		  (to set preferences)

http://download2cf.nemetschek.net/www_movies/2010/2d3d-Integration.mov
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Improved 3D Snapping
Product: Fundamentals

Vectorworks 2010 significantly enhances 3D snapping and working plane interaction with new options, capabilities, dynamic  
controls, and definitive indicators. Together, all of these new features provide more intuitive cursor control and feedback - and  
in turn, more precision and total confidence for accurately drawing, selecting, modifying, and aligning 3D objects.

Key new features for 3D snapping (with 3D tools and commands or the 3D Selection tool ) and working planes are  
summarized as follows:

Object Z height is now maintained for all dynamic movement operations.•	
Straight and round walls, floors, roofs, roof faces, and columns (and holes in these objects) now have multiple geometric  •	
and surface snap points.
Surfaces are now recognized for snapping and highlight automatically.•	
You can now “pick up” or select objects by key snap points (such as the center of a face), without having to click object edges.•	
Alignment indicators now emanate directly from acquired 3D smart points (they are no longer projected to the layer or active •	
working plane).
3D angle snaps are now available.•	
I, K, J coordinates have been renamed to X’, Y’, Z’ respectively.•	
Colored X’ (red), Y’ (green) , Z’ (blue) axis indicators are now displayed, with dashed extension lines and/or planar movement •	
indicators (shaded on plane, hollow off plane - in matching axis color).
Where applicable, all of these new features are compatible with the T key Smart Point and Smart Edge locks, floating  •	
datums, and the data bar or floating data bar (which now include more appropriate 3D context-sensitive fields, and new  
locking options for the Length and Angle fields).
The new •	 Modify > Working Plane menu provides single point access to all key working plane controls.
New overall and context-sensitive appearance improvements clearly identify the location and orientation of working planes, •	
while reducing screen clutter.
The new working plane manipulator widget now displays X’, Y’, and Z’ color-coded rotation handles on all axes, and uses  •	
the above snapping features for initial creation, repositioning, and changing orientation.
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Animation
Click here to view an animation of these features.

Access
Basic palette: 3D Selection tool  (or press Shift+X), and multiple other 3D tools, commands, and editing modes.
You can adjust 3D snap settings in the Vectorworks Preferences dialog box, Snapping palette, and SmartCursor Settings dialog box:
Menu: 	Tools > Options > Vectorworks Preferences, then select the Interactive tab
	 Window > Palettes > Snapping (or press Ctrl+Shift+C (Windows), Cmd+Shift+C (Mac))
	 Tools > SmartCursor Settings (or press Ctrl+8 (Windows), Cmd+8 (Mac))

New Planar Graphics
Product: Fundamentals

Vectorworks 2010 redefines 2D object display by introducing the new Plane property. This change means that all 2D-only  
drawing objects are now either:

Screen plane objects•	  - These objects look the same in any view because they don’t interact with 3D view changes  
(as in previous versions), or...
Layer plane objects•	  - These objects reside on an XY plane passing through the 0 (zero) Z elevation of the object’s design 
layer. These objects appear identical to screen plane objects in the Top/Plan view, but interact with 3D view changes. 

Some examples of the many uses for new layer plane objects include:
Displaying guidelines, reference geometry, or line-art type floor and ground markings in 3D views.•	
Reducing screen clutter while working in 3D views.•	
Indexing locations of objects on the floor or ground for reference, or before repositioning them in a 3D view  •	
(such as a the “current” furniture layout in a room - see Tips and Considerations below).
De-emphasizing geometry with a 2D representation in a 3D view (such as: adjacent buildings in a site plan; existingconditions; •	
showing the 2D proposed changes with 3D as-built geometry; or displaying walls and features removed by demolition). 

You should continue using screen plane graphics: 
If all graphics in the file will always  •	
be viewed in only Top/Plan view. 
To draw profile geometry for creating 3D  •	
objects (such as extrudes) in 3D views.
If your workflow in prior versions leveraged •	
interaction with objects that don’t react to  
3D changes (such as orthographic projections  
of lines and points).

http://download2cf.nemetschek.net/www_movies/2010/3D-Snapping.mov
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Access
You can select either Screen Plane or Layer Plane in the Planar drop-down list, which is available in many dialog boxes.  
Primary control points for planar graphics include:

Object Info palette and Properties dialog boxes (for drawing objects and viewports other than section viewports)
View bar -	 To set the document default behavior for the Top/Plan view, activate the Top/Plan view, and then select either  
	 Active Layer Plane or Screen Plane from the Active Plane drop-down list (which also displays any saved  
	 working planes in the current document).

Tips and Considerations
Keep in mind the following tips and considerations when using new planar graphics:

Text and object fills of layer plane objects are not displayed in 3D views.•	
Screen Plane•	  mode is mandatory for the Active Plane setting in 3D views. If you use 2D drawing tools to snap to  
objects in any 3D view (in mandatory Screen Plane mode), and then you change their Plane property to Layer Plane,  
the size and position will not be accurate. As before, you must still use 3D drawing tools to draw accurately in 3D views.
You may need to change the stacking order of layer plane objects to achieve the intended 3D display effect.•	
To create 2D indexing geometry from 3D or hybrid objects: Activate the (3D) Top view, and then select the object(s) to  •	
index. Use the Convert to Lines command (menu: Modify > Convert > Convert Copy to Lines) with the Hidden Line  
Rendering option. With the resulting group selected, change the display attributes (or edit the group) as desired, and  
then select Layer Plane in the Object Info palette.

Note: That if you select an object inserted in a wall, all other objects in the wall (and the wall itself) will automatically be 
	 included in the converted copy.
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New Dimensional Constraint Manager (DCM)
Product: Fundamentals

The new Dimensional Constraint Manager (DCM) provides more robust and reliable dimensional and geometric parametric  
constraints, and enables true bi-directional associativity with dimensions.

Animation
Click here to view an animation of these features.

Access
This feature is fully automatic, without user controls.

Interactive Dimension Editing
Product: Fundamentals

You can now modify geometry directly in the drawing area by changing an associative linear or chain dimension’s length value  
(see also New Dimensional Constraint Manager (DCM) and New Segment Position Control for Linear Dimensions.

Access
Double-click an associative linear or chain dimension, and then click or press Tab to select either end or the middle as the fix  
point. Enter the new length value, and then press Enter to incorporate the change.

Tips and Considerations
Keep in mind the following tips and considerations when using interactive dimension editing:

With interactive dimension editing, you can save time creating several types of objects and eliminate many complicated  •	
or time-consuming precision drawing procedures. Instead, draw objects quickly, in approximate proportion and size. You  
can then progressively refine the accuracy, first by dynamically dragging objects (using dimension values as feedback)  
to resize and reposition them, and then finally by editing dimensions to achieve the desired—and absolute—precision.
You can associate multiple linear or chain dimensions to the same object—even if the dimensions are created as  •	
viewport annotations—and change the object’s size from any associated dimensions.
You may find it helpful to lock specific dimensions (or objects) to prevent inadvertent changes when other dimensions             •	
are edited.
If a chain dimension won’t accept a length edit, decompose the chain dimension (to create individual dimensions)  •	
and try again.

http://download2cf.nemetschek.net/www_movies/2010/DCM_integration_final.mov
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Usability
Vectorworks 2010 significantly expands usability with the following improvements:

A new, standalone Help system.•	
More options and new capabilities for referencing, exchanging, managing, and purging data.•	
More intuitive interface changes, with faster and better feedback.•	
New tools and options for creating, displaying, selecting, and editing objects.•	
More options for creating and controlling dimensions.•	

New Help System Adobe AIR for Online Help
Product: Fundamentals

Vectorworks 2010 introduces a completely new and reliable help system which runs within Adobe AIR,  
a browser-independent application that provides:

Content layout and presentation consistency•	
Search and navigation enhancements•	
A Favorites tab, where you can save links to favorite topics, web pages, and RSS feeds•	
A Comments pod, where you can add notes to specific Help topics (double-click the comment  •	
to activate the corresponding help topic), and exchange notes with other users
The capability for updating at any time, with or without Vectorworks application service pack releases•	
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Animation
Click here to view an animation of these features.

Access
Menu: Help > Vectorworks Help
For context-sensitive Help, press F1, or Help, or ? (with or without a modifier key, depending on your operating system and              
keyboard configuration)

New Select Similar Tool
Product: Architect, Landmark, Spotlight, Machine Design

The new Select Similar tool  automatically selects all objects in a drawing (or a subset of objects in the active selection set)  
by matching any combination of 27 attribute criteria with an object you select. You can also save and recall attribute matching  
settings to ensure accuracy and facilitate commonly used selection scenarios.

http://download2cf.nemetschek.net/www_movies/2010/Interactive-Dimension-Editing.mov
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Animation
Click here to view an animation of these features.

Access
Basic palette: Select Similar tool . In the tool bar, choose either Select Any Object Mode  (to select all matching objects  
in the drawing) or Current Selection Mode  (to select matching objects in the active selection), and then click Preferences   
to specify attribute criteria to match.
To optionally save criteria settings: Click Save, then enter a name in the Assign Name dialog box, and click OK to save the settings  
for later recall by selecting them from the Active Settings drop-down list.

Tips and Considerations
With •	 Select Any Object Mode  active, hold down the Shift key to add or remove similar objects.
If a selection set is already active, activate the •	 Select Similar tool  (with Select Any Object Mode )  
and hold down the Shift key to remove similar objects from the active selection set.
Criteria settings are available for all drawings and are saved across Vectorworks sessions.•	

Easy Mapping of Associative Hatches
Product: Fundamentals

You can now use the improved Attribute Mapping tool  to dynamically move, rotate, and scale associative hatches  
(which are applied to objects through the Attributes palette).

http://download2cf.nemetschek.net/www_movies/2010/Select-Similar-Tool.mov
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Animation
Click here to view an animation of these features.

Access
Basic palette or Visualization tool set: Attribute Mapping tool  (or press Shift+A). You can either select the hatched  
object first and then activate the Attribute Mapping tool , or select the hatched object after you activate the tool.

Tips and Considerations
Keep in mind the following tips and considerations when mapping associative hatches:

You must be in Top/Plan view to edit layer plane objects with hatches.•	

New Global World Coordinates 
Product: Architect, Landmark, Spotlight, Machine Design 

You can now display and edit global world coordinates in the Object Info palette when a rotated view is active. 

http://download2cf.nemetschek.net/www_movies/2010/Mapping-Associative-Hatches.mov
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Access 
World coordinates are displayed in the Object Info palette for selected objects when a rotated view is active. You can toggle display 
settings for screen coordinates (or rotated plan coordinates) and world coordinates in the new Object Info palette preference menu 
(click the arrow  in the upper right corner). 

Note: When a rotated view is active, rulers and values for current plan rotation and screen coordinates are displayed in blue color. 

Improved Move by Points Tool 
Product: Fundamentals

New options for the Move by Points tool’s Reference Point Mode  lets you specify whether the first click is the reference  
point or a point on selected object(s). 

Access 
You can choose how to interpret the first click by selecting either the Reference Point or Object Point option in the Enter Offset  
dialog box. Basic palette:  Move by Points  (or press Shift+M), and then click two points. For objects in walls: Select the  
object, click Set Position in the Object Info palette, and then click two points. 
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Simultaneous Dimension Editing 
Product: Fundamentals

You can now use the Object Info palette to change settings (other than length value and fixed point) for individual and  
chain dimensions when both types are in the active selection set. 

Access 
Select at least one individual linear dimension and one chain dimension to display the settings in the Object Info palette. 

New Segment Position Control for Linear Dimensions 
Product: Fundamentals

Vectorworks 2010 adds a new widget to the Object Info palette that lets  you specify either end or the center as the fixed point  
of a linear dimension. If you change the dimension’s Length value, the other segments will move - while the fixed point remains 
stationary (see also Interactive Dimension Editing and New Dimensional Constraint Manager (DCM). 

Access 
Select a linear dimension, and then select a widget point (either end  
or center) in the Object Info palette to fix its position. Right-click a chain 
dimension segment and select Edit Dimension from the context menu, 
then select a widget point in the Object Properties dialog box to fix             
its position. 
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Tips and Considerations 
Keep in mind the following tips and considerations when using the new segment position control widget for linear dimensions:

The fixed point is the global setting for subsequently created dimensions. •	
The fixed point is ignored if you drag a dimension grip,or drag an object grip that the dimension is associated with. •	
If an error message is displayed and the dimension cannot be changed, the most likely cause is the unfixed end  •	
of the dimension is constrained to a locked object. 

New Dimension Standard Options 
Product: Fundamentals

Vectorworks 2010 provides easier access to default and custom dimension standards. The Custom Standards option  
has been added to the Dim Std drop-down list, which is now available from the Tool bar for the following tools: 

Constrained Linear Dimension•	  
Unconstrained Linear Dimension•	  
Angular Dimension•	  
Radial Dimension•	  
Center Mark•	   
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Access 
Dims/Notes tool set: (multiple tools). Select an existing standard from the Dim Std drop-down list, or select Custom Standards  
to create, import, or replace other standards. For existing dimensions, you can also access the Custom Standards option from  
the Dim Std drop-down list in the Object Info palette. 

Dimension Text Drag Support 
Product: Fundamentals

Vectorworks 2010 now lets you drag linear and chain dimension text in any direction, without affecting the dimension line location. 

Note: Text for angular or arc length dimensions can only be moved along the curve of the dimension line. 

Access 
You can drag linear and chain dimension text with the 2D Selection tool: 
Basic palette: 2D Selection  (or press X) 

Chain Dimension Text Collision Control 
Product: Fundamentals

The new Use collision control when placing chain dimension text option (on by default) automatically offsets chain dimension 
length values to prevent overlapping dimension text. 

Access 
Dims/Notes tool set: Constrained Linear Dimension  (or press N)   
or Unconstrained Linear Dimension  (or press M). Click Chain Dimension 
Preferences  from the Tool bar, and then toggle the Use collision control 
when placing chain dimension text option in the Chain Dimension  
Preferences dialog box. 
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New Arc Length Dimension Tool 
Product: Fundamentals

The new Arc Length Dimension tool  lets you dimension any portion of an arc along its circumference. 

 
Access 
Dims/Notes tool set: Arc Length Dimension 

Tips and Considerations 
Keep in mind the following tips and considerations when using the new Arc Length Dimension tool: 

To facilitate snapping to any point on an arc (when no other intersecting geometry is present),  •	
press the T key when your cursor is on the arc to set a temporary surface snap. 

Fractional Dimension Display 
Product: Fundamentals

The new Fractional Display for Dimensions preference settings in the Units dialog box let you choose from three different  
fractional dimension display styles: 

Un-stacked•	  - Fraction text is the same size as non-fraction text with a 45 degree fraction line. This is the same style  
used in Vectorworks 2009. 
Diagonally stacked •	 - Fraction text is half the size of non-fraction text with a 45 degree fraction line. 
Vertically stacked•	  - Fraction text is 45% of the size of non-fraction text with a horizontal fraction line. 

Note: This preference will only affect dimension text in dimensions and chain dimensions. 



22     Vectorworks 2010 Version

Vectorworks 2010 Your Guide to What’s New

Access 
Menu: File > Document Settings > Units 

Improved DXF/DWG Reference Import Support 
Product: Fundamentals

Vectorworks 2010 introduces four new options for importing DWG/DXF files with external references (xRefs): 
Bind External References•	  - Eliminates external files by importing the master DXF/DWG file and all its xRefs  
into a single Vectorworks file. This default option is the same as previous versions. 
Ignore External References•	  - Imports only the master DXF/DWG file and disregards all xRef files. 
Use Design Layer Viewports•	  - Imports the master DXF/DWG file and all its xRefs into separate Vectorworks files.  
External files are automatically referenced into the master Vectorworks file in separate referenced design layer  
viewports (Design Series), or layer links (Fundamentals). 
Use Layer Import•	  - Imports the master DXF/DWG file and all its xRefs into separate Vectorworks files. External  
files are automatically referenced into the master Vectorworks file using the layer import referencing method. 

Access 
You can select options for xRefs in the new References section of the DXF/DWG Import dialog box: 
Menu: File > Import > Import DXF/DWG 

Tips and Considerations 
Keep in mind the following tips and considerations when the new options for importing DWG/DXF files with external references (xRefs):

All four options are available in Design Series products. For other products, the •	 Use Design Layer Viewports  
option is not available. 
The •	 Use Design Layer Viewports and Use Layer Import options are only available when the Destination is  
set to New Files in Folder. 
Clipped xRefs and all other clipped DWG block instances will be imported as cropped design layer viewports  •	
(or layer links), or the layer import referencing method will be used. 
If the master DXF/DWG file has multiple xRefs with identical layer structures, select the •	 Use Design Layer Viewports option. 
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DXF/DWG Import Saved Settings 
Product: Fundamentals

Vectorworks 2010 now lets you save and recall  
DXF/DWG import option settings. 

Access 
Menu: File > Import > Import DXF/DWG 

Process Overview 
The following steps describe the general process for saving        
DXF/DWG import settings:

From the menu, select 1.	 File > Import > Import DXF/DWG. 
In the DXF/DWG Import dialog box: 2.	

Adjust settings for Source,  •	
	 Destination, and References. 

In the Import Options section, click                                 	•	
	 Set Custom Options. 

In the DXF/DWG Import Options dialog box: 3.	
Change settings as required in the Primary Settings, Graphic Attributes, or Objects tabs. You must change settings  •	

	 before you can save the settings. Otherwise, the Use Settings drop-down list reverts to the Default option. 
In the Use settings section, click •	 Save as, and then specify the Name in the Save Settings dialog box, and click OK. 

Click 4.	 OK to close the DXF/DWG Import Options dialog box, and then click OK in the DXF/DWG Import dialog box to  
complete the import operation. 

	 The saved setting is now available for all import operations in the Use Settings drop-down list. 

Tips and Considerations 
Keep in mind the following tips and considerations when saving DXF/DWG import settings: 

Import settings are saved as XML files in your user folder. Typical folder locations for these files are: •	
	 Windows:	C:\Documents and Settings\[Current User]\Application Data\Nemetschek\Vectorworks\2010\Settings\DWG_DXF 	
	 Mac:        	/Users/[Current User]/Library/Application Support/Vectorworks/2010/Settings/DWG_DXF 

The •	 Default option restores import settings that ship with Vectorworks. 
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Import Support for AutoCAD® Scaled Blocks 
Product: Fundamentals

During DXF/DWG import, AutoCAD scaled blocks will now be imported as Vectorworks symbols. For each different  
scale of the      DXF/DWG file’s block, on Vectorworks symbol definition will be created and instanced as required. 

Note: In some cases, nested scaled symbols will be imported as groups. 

Access 
This feature is fully automatic, without user controls. 

Support for 128 Dash Styles 
Product: Fundamentals

Vectorworks 2010 can now hold up to 128 dash styles -  
so all dash styles will import, and your existing Vectorworks  
dash styles will not be overwritten. 

Access 
This feature is fully automatic, without user controls. 

Import 2D or 3D View of ADT objects 
Product: Fundamentals

A new option in the DXF/DWG Import dialog box lets you        
choose whether the 2D view or 3D view of architectural  
objects will be imported. 

Access 
You can choose 2D View (default) or 3D View in the  
Architectural Objects section of the DXF/DWG Import dialog box: 
Menu: File > Import > Import DXF/DWG 
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AutoCAD® Table Import Support 
Product: Fundamentals

Vectorworks 2010 now imports formatted tables as lines and text with their proper attributes: 
Line style •	
Line thickness •	
Color •	
Size •	

Access 
This feature is fully automatic, without user controls. 

New Custom Dimension Standards 
Product: Fundamentals

Custom dimension standards are now automatically created when dimensions are imported from DXF and DWG files. 

Access 
Menu: File > Import > Import DXF/DWG 
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SketchUp 7 Import Support 
Product: Fundamentals

Vectorworks 2010 now supports SketchUp 7 so you can import geometry from the latest version of SketchUp  
and content from Google’s 3D Warehouse. 

Access 
Menu: File > Import > Import SketchUp 
Google 3D Warehouse website: sketchup.google.com/3dwarehouse 

DXF/DWG Batch Export of Saved Views 
Product: Fundamentals

You can now batch export saved views to separate DXF or DWG files. Two new options are now available in the  
DXF/DWG Export Options dialog box’s Export drop-down list: 

All Saved Views•	  - all existing saved views in the document are exported. 
Selected Saved Views•	  - lets you select which saved views in the document are exported. 

Note: If there are no saved views in the document, these options are not displayed. 

Access 
Menu: File > Export > Export DXF/DWG 

sketchup.google.com/3dwarehouse
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DXF/DWG Anonymous  
Block Export Support 
Product: Fundamentals

You can now export groups as anonymous blocks. 

Access 
You can toggle the Export Groups as Anonymous Blocks 
option in the DXF/DWG Export Options dialog box: 
Menu: File > Export > Export DXF/DWG 

DXF/DWG Export of Sheet  
Layers as 2D Graphics 
Product: Fundamentals

The new Export Viewports as 2D graphics in Model Space option in the DXF/DWG Export Options dialog box lets you export  
2D and 3D Vectorworks sheet layer viewport graphics to AutoCAD model space as 2D objects. When this option is enabled: 

Graphics from Top/Plan viewports are exported (as in Vectorworks 2009)  •	
without conversion to 2D lines. 
Graphics from rendered 3D view viewports are exported via the  •	
Convert to Group command, which maintains crop objects  and  
rendering background/foreground settings. 
Graphics from 3D view viewports, not rendered, in any orthogonal  •	
view are exported via the Convert to Group command after updating  
with Hidden Line rendering mode, with appropriate scaling. 
Graphics from 3D view viewports, not rendered, in any isometric  •	
or Custom view are exported via the Convert to Lines command,  
with appropriate scaling. 
Section viewports are exported via the •	 Convert to Group  
command, with appropriate scaling. 
All annotations attached to viewports will be exported  •	
as single entities.
All other non-viewport sheet layer graphics (such             •	
as Title blocks) will also be exported to model  
space (paper space graphics will not be created). 

Access 
You can toggle the Export Viewports as 2D graphics  
in Model Space option in the Sheets to Include section  
of the DXF DWG Export Options dialog box: 
Menu: File > Export > Export DXF/DWG 
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Tips and Considerations 
Keep in mind the following tips and considerations when exporting sheet layers as 2D graphics to DXF/DWG files: 

This option is only active when sheet layer(s) are exported. •	
If you re-import the exported file, all graphics will be imported into a design layer. •	
When this option is enabled, and more than one sheet layer is selected for export, the •	 Export Layers  
as Separate Files option will automatically be enabled (and grayed). Exporting to separate files prevents  
interference with objects from multiple sheet layers in model space. 

Improved IFC Export 
Product: Architect 

Architectural symbol content in Vectorworks Architect is now pre-categorized with IFC data. 

Access 
Menu: File > Export > Export IFC Project or Export IFC Object 

 
New Viewport Visibility Options 
Product: Architect, Landmark, Spotlight, Machine Design 

A new option for sheet layer viewports maintains class and layer  
visibilities in non-referenced design layer viewports when they are  
displayed in the sheet layer viewport. 

Access 
Select a sheet layer viewport, and then click Layers or Classes  
in the Object Info palette. You can then toggle the Layer Visibility  
or Class Visibility options in the “Use embedded design layer 
viewport settings for:” section. 

Note: 	When these options are enabled, class and layer visibilities 	
	 in sheet layer viewports are ignored. 
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Improved File Referencing Capabilities 
Product: Fundamentals

When you update referenced files in Vectorworks 2010, the new Referenced Resource Not Found dialog box automatically  
provides three options for each missing referenced resource: 

Break the reference•	  
Delete the resource •	
Replace the resource with•	  - Activates a drop-down list where you can select a different resource from the source file,  
which will then replace the definition and all instances of the missing resource. This option disables the OK To All button. 

Access 
The Referenced Resource Not Found dialog box is only displayed if a referenced resource is missing when the referenced file is 
updated. Referenced files can be set to update automatically when the target file is opened. You can manually update all or individual 
referenced files in the References tab of the Organization dialog box: 
Menu: Tools > Organization, and then select the References tab. Select one reference, or hold down the Shift key and select multiple 
references, then click Update. 

For Design Series products, referenced files are also listed in the References tab of the Navigation palette: 
Menu: Windows > Palettes > Navigation, or right-click a blank area of the drawing for the context menu: Palettes > Navigation. 
Select one reference, or hold down the Shift key and select multiple references. You can then either right-click the selection and  
select Update from the context menu, or select Update from the Navigation palette menu (arrow) . 



30     Vectorworks 2010 Version

Vectorworks 2010 Your Guide to What’s New

In-Place Reference Editing 
Product: Fundamentals

You can now edit referenced resources in the host file in the same manner as local resources (without opening the source file).  
Any edits to referenced resources in the host file are automatically saved to the resource’s definition in the source file. This new  
editing capability is available for: 

Gradients •	
Hatch definitions •	
Record formats •	
Render backgrounds •	
Symbol definitions (including plant definitions) •	
Symbol instances of referenced symbols (so you can •	
modify them in context of other objects in the target file) 
Sketch styles •	
Textures •	
Wall styles •	

Animation 
Click here to view an animation of these features. 

Access 
Right-click a referenced resource in the Resource Browser and select Edit from the context menu. 

Tips and Considerations 
Keep in mind the following tips and considerations when editing referenced resources in the host file: 

The source file cannot be open when you edit referenced resources in the host file. •	
If you edit instances of referenced symbols, be sure to enable the •	 Show other objects while in editing modes option  
in the Display tab of the Vectorworks Preferences dialog box (menu: Tools > Options > Vectorworks Preferences). 

http://download2cf.nemetschek.net/www_movies/2010/In-Place-Reference-Editing.mov
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Improved Viewport Crop Editing 
Product: Fundamentals

In Vectorworks 2010, the new Display Viewport Outside Crop option for Edit Crop mode lets you edit sheet layer and design layer 
viewport crops within context of the entire viewport. You can now choose to display objects outside the crop either as gray or wireframe 
objects. This option facilitates the process of expanding crop objects, and also lets you snap to objects outside the crop. 

Animation 
Click here to view an animation of these features. 

Access 
You can toggle the Display Viewport Outside Crop and             
Gray Outside Crop options in the Edit Viewport dialog box: 
Menu (with a viewport already selected): Modify > Edit Viewport, 
or right-click a viewport and select Edit from the context menu. 

Tips and Considerations 
Keep in mind the following tips and considerations when    
displaying objects outside the viewport crop:

These are system-level settings, saved across     •	
Vectorworks sessions. 
These options are not available for editing layer link crops. •	
These options are not affected by the •	 Show other objects while in editing modes  
settings in the Display tab of the Vectorworks Preferences dialog box. 

Improved Elevation Benchmark 
Product: Architect, Landmark, Spotlight, Machine Design 

The new Crosshair Scale Factor parameter for the Elevation Benchmark lets you extend the crosshair marks beyond the marker circle. 
The default (minimum) value of 1 does not extend lines beyond the circle, as in previous versions. A value of 2 extends lines beyond the 
circle by the radius of the circle. Other values (including fractional values) extend the lines by a factor based on the circle size. 

Access 
You can change the Crosshair Scale Factor value in the Object Properties dialog box or Object Info palette. Dims/Notes tool set: 
Elevation Benchmark , and then click Preferences  from the Tool bar. For existing elevation benchmark objects, change  
the value in the Object Info palette. 

Note: The Crosshair Scale Factor parameter is only available in the Object Info palette when the US Style is active. 

http://download2cf.nemetschek.net/www_movies/2010/Viewport-Crop-Editing.mov
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New Find Resource Capability 
Product: Fundamentals

A new search location option in the Find Resource dialog box lets you quickly locate resources within the current document. 

Access 
Choose the new Current file option (or Files on disk, to search like previous versions) in the Find Resource dialog box’s  
Search Location section: Resource Browser menu: Find Resource (or right-click the Resources area and select Find Resource  
from the context menu) 

Resource Browser View Enhancement 
Product: Fundamentals
The Resource Browser now displays up to five lines of text for resource names (in thumbnail view mode). 

Access 
This feature is fully automatic, without user controls. 

 

Multi-Processor Support 
Product: Fundamentals

All of the Parasolid-based functionality in Vectorworks 2010  
now takes advantage of multi-processing on the Macintosh. 

Access 
This feature is fully automatic, without user controls. 
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New Dash Style Capabilities 
Product: Fundamentals

Vectorworks 2010 includes the following dash styles improvements: 
Up to 128 dash styles are now supported. •	
You can now name and reorder dash styles in the Dash Styles dialog box. •	
You can now edit dash styles from the Attributes palette’s Line Style •	
drop-down list. Also, the new Convert Line to Dimension command 
replaces the dimension line style that was previously available from  
the Line Style drop-down list. 
Default dash styles are now stored in the •	 Default Dash Styles.xml  
file  in the default content folder: 

	 [Vectorworks application folder]\Libraries\Defaults\Attributes 	
	 - Dash Styles folder 

Access 
You can manage dash styles in the Dash Styles dialog box: 
Menu: File > Document Settings > Dash Styles. Select a dash style from the list and then click New or Edit. 
Attributes palette: Select Edit Dash Styles from the Line Style drop-down list. 
To convert a line to a dimension, select the line and then select Modify > Convert > Convert Line to Dimension from the menu. 

New Purge Capabilities 
Product: Fundamentals

The Purge Unused Objects command has been renamed to Purge, and enhanced with new options that let you: 
Purge specific empt•	 y symbol folders. 
Purge objects outside of the page boundary. •	
Selectively purge plug-in object symbols and group symbols. •	
Purge record formats that store plug-in object defaults. •	
Purge unused dash styles. •	
Undo and redo purges. •	
Preview and confirm the se•	 lected items to be purged. 

Access 
Menu: Tools > Purge 
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Improved 2D Reshape Tool 
Product: Fundamentals

Vectorworks 2010 adds new options for the 2D Reshape tool : 
A new mode group in the Tool bar lets you enable •	 Rectangular, Lasso, or Polygonal Marquee selection  
modes to specify which geometry will be moved by dragging, the Move command, or nudging. 

Note: 	As in Vectorworks 2009, pressing Alt (Windows) Option (Mac) temporarily activates lasso marquee mode; 
	 pressing Shift+Alt (Windows) or Shift+Option (Mac) temporarily activates polygonal marquee mode. 

You can now hold down the Shift key to draw marquee •	
selections when the start point is on a filled object. You  
no longer have to click outside the filled object to start 
drawing the marquee. 

Animation 
Click here to view an animation of these features. 

Access 
Basic palette: 2D Reshape  (or press - (hyphen), or double-click 
a 2D object. 

New Rectangle Modes 
Product: Fundamentals

Vectorworks 2010 adds two new modes for the Rectangle tool : 

Center and Corner Rectangle•	   
Side Center and Opposite Corner Rectangle•	   -  
Hold down the Alt key (Windows) or Option key (Mac)  
to start the first point from the center of a vertical side. 

Access 
You can select new modes (Center and Corner Rectangle , 
and Side Center and Opposite Corner Rectangle  for creating 
rectangles in the Tool bar: Basic palette: Rectangle  (or press 4) 

http://download2cf.nemetschek.net/www_movies/2010/2D_reshape_selection_tools_enhancements.mov
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New Circle Modes 
Product: Fundamentals

Vectorworks 2010 adds two new modes for the Circle tool : 
Circle by Point and Center•	  
Circle by Tangent and Center•	    

Access 
You can select new modes (Circle by Point and Center , and 
Circle by Tangent and Center  for creating circles in the Tool bar: 
Basic palette: Circle  (or press 6) 

New Arc Mode 
Product: Fundamentals

Vectorworks 2010 lets you create an arc by its circumference with the new Arc by Arc Length and Chord Length  mode for the 
Arc tool : 

Access 
You can select the new Arc by Arc Length and Chord Length  mode in the Tool bar: Basic palette: Arc  (or press 3) 
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Connect/Combine Tool Support for Multiple Objects 
Product: Fundamentals

The new Multiple Object Connect Mode  for the Connect/Combine tool  lets you extend multiple objects to a single boundary 
object. After you select a boundary object, select other objects (one at a time) to extend them to the highlighted boundary object. If you 
then click in a blank area of the drawing, the current boundary is deselected - but the Connect/Combine tool is still active. You can 
then select a new boundary object and continue to select objects to extend. 

Animation 
Click here to view an animation of these features. 

Access 
Basic palette: Connect/Combine tool , or press the “;” key 

Chamfer by Length Option 
Product: Fundamentals

The new Chamfer Line Length option in the Chamfer Settings dialog box lets you specify the length of the chamfered edge for 
symmetrical chamfers. 

Animation 
Click here to view an animation of these features. 

Access 
Basic palette: Chamfer 

http://download2cf.nemetschek.net/www_movies/2010/Connect-Combine-Support-for-Multiple-Objects.mov
http://download2cf.nemetschek.net/www_movies/2010/Chamfer-by-Length.mov


Vectorworks 2010 Version     37

Vectorworks 2010 Your Guide to What’s New

Shortcut Support for Modification Tools 
Product: Fundamentals

In Vectorworks 2010, you can now temporarily hold down a modifier key and select objects while the following tools are active: 
Rotate•	   
Mirror•	  
Offset•	   
Move by Points•	   

Note: 	For operational consistency, the Offset tool’s Click Object to Offset Mode and Offset Selected Objects Mode options have 		
	 been removed from the Tool bar. 

Animation 
Click here to view an animation of these features. 

Access 
Basic palette: 	Rotate , (or press Alt+= (Windows), Option+= (Mac)), Mirror  (or press =), 
	 Offset  (or press Shift+- (hyphen)), Move by Points  (or press Shift+M) 

When these tools are active, hold down the Alt key (Windows) or Command key (Mac) to temporarily activate the    
2D Selection tool . After selecting objects, release the Alt or Command key to return to the active tool. 

http://download2cf.nemetschek.net/www_movies/2010/2D_reshape_selection_tools_enhancements.mov
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Visibility Tool Improvements 
Product: Fundamentals

Vectorworks 2010 includes the following Visibility tool improvements to telegraph and confirm visibility changes: 
Scree•	 n hint - The name of the class or layer that will be affected is now displayed as a tool tip (near the cursor). 
Tool highlighting•	  - When you move the cursor over selectable objects, all objects of the same class or layer are now highlighted. 
Status display•	  -After the visibility is changed, the name of the affected class or layer and a description of the change are now 
displayed in the Message bar. 

Access 
Basic palette: Visibility 

Set Origin Improvements 
Product: Fundamentals

Vectorworks 2010 introduces two new features to prevent inadvertently resetting the drawing origin with the cursor: 
When you click or drag the •	 Set Origin button , an alert dialog box is now displayed. 
You can now disable the •	 Set Origin button  for all files. 

Access 
You can toggle the Disable dragging for the Set Origin button option in the Set Origin or alert dialog boxes. 
Menu: Tools > Set Origin, or click Set Origin button , at the intersection of the drawing area rulers. 

Ignore Priority of References when Updating References 
Product: Architect, Landmark, Spotlight, Machine Design 

The new Use reference priority when updating references option in the Reference Settings dialog box controls whether referenced 
resources are always updated from the source file (disabled), or updated according to the reference priority set in the References tab  
of the Organization dialog box (enabled). For predictable reference performance, this option should be: 

Disabled if•	  the current document’s resources are referenced from multiple source files to update each referenced resource from 
the original source file. This will prevent you from inadvertently changing the source file of a referenced resource if you change 
the priority order, or if you update an individual reference (instead of all references). 
Enabled if the current document’s resources are not referenced from multiple source files, or if you need references updated  •	
in the priority order regardless of multiple sources for referenced resources. 

Note: 	By default, the Use reference priority when updating references option is disabled for new files, and enabled for 
	 files migrated from earlier versions. 



Vectorworks 2010 Version     39

Vectorworks 2010 Your Guide to What’s New

Access 
You can toggle the Use reference priority when updating references option in the Reference Settings dialog box: 
Menu: Tools > Organization, then select the References tab and click Settings 

Floating Data Bar Positioning 
Product: Fundamentals

Vectorworks 2010 adds two new options to the Tool bar menu: 
Show floating data bar below SmartCursor cues•	  (default) - Same positioning as previous versions of Vectorworks 
Show floating data bar above SmartCursor cues •	 - For touch screens and tablets where the floating data bar would  
otherwise be obscured by cursor interaction. 

Access 
Right click a blank area of the Tool bar, or click  on the far right side to toggle Floating Data bar options. 

Update Viewports Prior to Printing 
Product: Fundamentals

To prevent inadvertently sharing or releasing inaccurate data from outdated viewports, you can now choose to automatically update  
all visible outdated sheet layer viewports before printing or exporting to PDFs and image files. 

Access 
You can toggle the Update visible out of date viewports prior to printing or exporting option in the Print, Export PDF, and Export 
Image dialog boxes: 

Menu: 	File > Print or Batch Print 
	 File > Export > Export PDF or Export PDF (Batch) 
	 File > Export > Export Image File 
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Tips and Considerations 
Keep in mind the following tips and considerations when updating viewports prior to printing: 

The •	 Update Viewports prior to exporting option is enabled by default. 
This setting is saved across Vectorworks sessions. •	

Reset Dependent Plug-ins Prior to Printing and Exporting 
Product: Fundamentals

To prevent inadvertently sharing or releasing inaccurate data, you can now choose to automatically reset all plug-in objects  
that require a reset before printing or exporting to PDFs and image files. 

Access 
You can toggle the Reset all plug-in objects that require a reset prior to printing or exporting option in the Print, Export PDF,  
and Export Image dialog boxes: 

Menu:	File > Print or Batch Print 
	 File > Export > Export PDF or Export PDF (Batch) 
	 File > Export > Export Image File 

Combined General Display and Dimension Panes on Units Dialog 
Product: Fundamentals

The following changes in the Units dialog box now clearly show how preference settings for drawing precision affect                         
dimension precision: 

Settings from the General tab and Dimension Objects (Primary) tab were consolidated in the new General Display  •	
and Dimensions tab. 
Dimension precision and rounding base values can now be linked to general display precision and rounding base values. •	
Precision settings are now maintained when you change the Units setting from one metric unit to a different metric unit  •	
(values are automatically scaled by the same ratio). 



Vectorworks 2010 Version     41

Vectorworks 2010 Your Guide to What’s New

Access 
Menu: File > Document Settings > Units 

Select All Edges in Chamfer Edge Tool and Fillet Edge Tool 
Product: Fundamentals

Vectorworks 2010 includes a new option for the Chamfer Edge tool and Fillet Edge tool that lets you instantly select all of a 3D  
solid object’s edges. 

Access 
3D Modeling tool set: Chamfer Edge tool . In the Tool bar, click Chamfer Edge Preferences  and enable the Select  
All Edges option. Fillet Edge tool . In the Tool bar, click Fillet Edge Preferences  and enable the Select All Edges option. 

New Properties Dialog for Structural Shapes 
Product: Fundamentals

New Series and Size drop-down lists in the Object Properties dialog box let you select standard sizes of default content for  
document defaults or creating and modifying the following 2D and 3D structural plug-in objects: 

Angle •	
Bulb Flat •	
Channel •	
I-Beam •	
Rectangular Tubing •	
Round Tubing •	
Square Tubing •	
Tee •	
Wide Flange •	
Z-Sectio•	 n 
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Access 
Detailing tool set: Select a structural tool and then click to insert a structural shape in the drawing and display the Object  
Properties dialog box. The first selection for a new file sets the document default. Click Preferences  to change document  
defaults. Double-click existing structural shapes to modify them (without affecting document default settings). 

Real-Time Updating During Slider Dragging 
Product: Fundamentals

Vectorworks 2010 improves dynamic interaction with dialog box settings by updating graphical previews and numerical values  
in real-time as you drag slider controls. 

Access 
(Multiple preference and tool settings dialog boxes) You can see examples of how this feature works in the Vectorworks  
Preferences dialog box: 
Menu: Tools > Options > Vectorworks Preferences, then select the  Interactive tab and drag either slider control. 

Improved Window and Door Insertion 
Product: Fundamentals

Vectorworks 2010 now provides reliable and predictable wall texturing around windows and doors by using “hidden” wall  
cutting objects to create window and door openings. 

Access 
This feature is fully automatic, without user controls. 
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Vectorworks Architect 
Vectorworks Architect 2010 extends Building Information Model (BIM) capabilities with the following design and  
documentation enhancements: 

New wall shaping tools, wall joining connection options and controls. •	
New editing and texturing options for wall holes. •	
True corner windows. •	
A new •	 Stair tool for complex configurations with extensive display controls and options. 
Wall networks are now more stable and behave predictably when you control them either dynamically by dragging,  •	
or precisely with combinations of geometric constraints and bi-directionally controlled dimensions. 
Simplified interfaces and more efficient tools. •	
A new automatic drawing coordination option ensures accurate reference data by linking drawing views with their markers. •	
New display options or configuration capabilities for columns, callouts, keynote legends, and the Notes Manager. •	
New or improved structural objects, symbols, and resources. •	

Improved Wall Networks 
Product: Architect 

Vectorworks 2010 significantly improves wall network (connected 
walls) functionality and stability with the Dimensional Constraint 
Manager (DCM) from Siemens PLM, which enables: 

New heights in design productivity with simultaneous •	
control of walls with interactive dimensions and geometric 
constraints, without disconnecting wall segments when 
either is modified. 
More varieties of wall and component joins that are •	
substantially more flexible and robust. 

Animation 
Click here to view an animation of these features. 

Access 
This feature is fully automatic for connected walls, without Vectorworks controls or options. 

http://download2cf.nemetschek.net/www_movies/2010/DCM_integration_final.mov
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 Wall Sculpting 
Product: Architect, Landmark, Spotlight, Machine Design 

New wall sculpting commands let you modify existing walls to create custom wall shapes and components by adding or removing 
volume, while preserving wall intelligence, behaviors, and hybrid display properties. You can use 2D or 3D source geometry—or  
even 3D or hybrid symbols—to create wall projections and wall recesses (both types of the new Feature in Wall object), and precisely 
control how wall components wrap around them. 

Access 
Menu: 	AEC > Create Wall ProjectionAEC > Create Wall Recess Modify > Add Surface to create a wall projection (without symbols)		
	 Modify > Clip Surface to create a wall recess (without symbols) 

Process Overview 
The following steps describe the general process for creating wall projections and recesses: 

Draw the wall(s) you want to sculpt. 1.	
Determine if the sculpting feature will be generated from source geometry: 2.	

That defines the core (inside) or outside (extents). •	
Drawn as a 2D-only object - which can’t be saved as a symbol, and is extruded so it •	 always has vertical side  

	 edges and horizontal top and bottom edges. 
Modeled as a 3D object - which can be saved as a symbol, and can have edges of any shape and orientation. •	
Created from both 2D and 3D objects - if you want to create a hybrid symbol (see Tips and Considerations below). •	

Create as many 2D or 3D objects as needed—based on determinations from the previous step—to define the sculpting  3.	
feature source geometry, which: 

Must be positioned such that at least one edge or face contacts (or intersects) the wall to be sculpted. •	
Must define a 2D area or 3D volume. •	
Must not have: edges that fold back on themselves; self-contacts; or self-intersections. •	
Must not extend along the entire length of the wall to be sculpted. •	
Can optionally be saved as either a 3D or hybrid symbol: Leave the first instance in-place, and then  •	

	 copy or insert additional instances as required; do not insert symbols in the wall. 



Vectorworks 2010 Version     45

Vectorworks 2010 Your Guide to What’s New

Hold down the Shift key, then select the source geometry object(s) you created in the previous step, and the  4.	
wall segment you want to sculpt. To create a: 

Wall projection by adding volume, continue with step 5. •	
Wall recess by removing volume, proceed to step 6. •	

From the menu, select 5.	 AEC > Create Wall Projection. In the *Create Wall Feature Projection dialog box, specify: 
The feature component. •	
Right and left wrap settings. •	
The Offset From Wall Top value. •	
Options for the profile core and object 3D attributes, and then proceed to step 7. •	

From the menu, select 6.	 AEC > Create Wall Recess. In the *Create Wall Feature Recess dialog box, specify: 
Right and left wrap settings. •	
The Offset From Wall Top value. •	

Click 7.	 OK to close the Create Wall Projection Feature dialog box and create the sculpting feature. 
With the new Feature In Wall object still selected, adjust physical or display *settings as necessary in the Object Info palette. 8.	
If necessary, you can edit the Feature In Wall object’s source geometry by double-clicking the feature to activate wall feature 9.	
editing mode (identified by an orange border, which looks and works similar to symbol editing mode). 

Tips and Considerations 
Keep in mind the following tips and considerations when creating wall projections and recesses: 

As with other 3D modeling operations, feature creation order determines how wall sculpting features affect the wall and each •	
other. For example, create an intersecting recess after a projection if you want the recess to remove volume from the projection. 
Wall styles without components cannot have the •	 Use Class Attributes option enabled for the Pen settings (in the Wall          
Definition tab of the Edit Wall Style dialog box, click Edit Wall Attributes to display the Wall Attributes dialog box). 
Use 3D or hybrid symbols for wall projections and recesses (2D only symbols are invalid), so you can share them with  •	
other files and users via importing/exporting, referencing, or placing them in default content files. If you use hybrid symbols  
to create wall projections or recesses, the symbol’s 2D geometry is ignored. 
Changing a wall feature’s class property to an invisible class only removes the 2D representation in the Top/Plan view  •	
(the 3D sculpting feature itself is controlled by the host wall’s class). 
When you need to select wall sculpting features in 3D views, you may find it helpful to use pre-selection highlighting. •	
Extend wall recess source geometry well outside of the wall’s boundary. The excess volume is ignored when the feature  •	
is created, but is still beneficial for wall thickness changes, or for selecting wall recess features by their “cutting volume” 
boundary in 3D views. 
If you’re having trouble selecting a wall projection feature in 3D views, briefly move the cursor away from the feature  •	
(before selecting anything), and then try again. 
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Improved Drawing Coordination 
Product: Architect, Landmark, Spotlight, Machine Design 

A new option for automatic drawing coordination ensures annotation accuracy by linking sheet and drawing numbers of viewports or 
plug-in objects on sheet layers with their corresponding drawing label or markers. When the Use Automatic Drawing Coordination 
option is enabled, reference data between the following objects is automatically managed: 

Sheet borders with title blocks •	
Drawing labels •	
Reference markers •	
Sheet layer viewports •	
Section viewports and section lines •	

The following new properties facilitate automatic drawing coordination: 
Sheet Number for sheet layers •	
Sheet Title for sheet layers •	
Drawing Number for section viewports •	
Drawing Title for sheet layer and section viewports •	
Description for design layer viewports (specified in the Drawing Title field at creation) •	

Other new options or changes for streamlining automatic drawing coordination include: 
New options for the Create Section Viewport dialog box let you automatically name the viewport  •	
with the item and sheet, create a drawing label, and specify the drawing number and drawing title. 
The Section column is now also displayed on the Navigation palette’s Viewports tab. •	
The Layer drop-down list (in all UI elements) now displays the sheet number and [sheet title]  •	
(in square brackets) for  sheet layers. 
Drawing Borders have been renamed to Sheet Borders. •	

Note: 	See all Tips and Considerations below for additional information, and refer to the online help system for fully specific rules, 
	 detailed instructions and complete coverage for all options. 

Animation  
Click here to view an animation of these features. 

Access 
(Multiple tools, commands, and dialog boxes) You can toggle  
the Use Automatic Drawing Coordination option in the  
Display tab of the Document Preferences dialog box: 
Menu: 	File > Document Settings > Document Preferences,  
or right-click a blank area in the drawing and select 	
Document Preferences from the context menu. 

http://download2cf.nemetschek.net/www_movies/2010/Drawing-Coordination.mov
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Tips and Considerations 
Keep in mind the following tips and considerations when using automatic drawing coordination: 

All automatic drawing coordination features are designed to work with one sheet border per sheet layer. •	
If there are no sheet borders in the document, drawing labels and markers display the Sheet Number property  •	
from the sheet layer. Title blocks—if present in a sheet border—are coordinated with the Sheet Number, and  
provide access for editing the Sheet Number. 
You can edit the sheet number from a drawing border, Organization dialog box, or Navigation palette -  •	
but not from a drawing label or section line. 
You can edit the drawing number from a drawing label - but not from a section line. •	
You can’t move a sheet layer object to a different sheet layer by changing its marker’s linked data field. For example,  •	
you can’t move a section viewport to another sheet layer by changing the Sheet Number property of its section line instance. 

New Corner Window 
Product: Architect 

Vectorworks Architect 2010 now lets you create true corner windows with the following corner conditions: 
Flush Glass•	  (no sash or post at the corner) 
Mitered Sash•	  (only sash at the corner; no post) 
Corner Post•	  (specify the post size and offset) 

Access 
For a new window, enable the Corner Window option in the Window Settings dialog box’s General tab, and then click Corner Window 
Settings: Building Shell tool set: Window  (or press Shift+D), and then click Preferences  in the Tool bar. For existing selected 
windows, scroll down in the Object Info palette and enable the Corner Window option (the window automatically moves to the nearest 
corner), and then adjust settings as necessary. 
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New Stair Tool 
Product: Architect, Landmark, Spotlight, Machine Design 

Vectorworks Architect 2010 introduces a new robust and comprehensive Stair tool  that lets you create stair plug-in objects  
with extensive configuration and display options. The new Stair tool complements the existing Simple and Custom Stair tools. 
Use the new Stair tool to create stairs that: 

Are too complex for accurate representation with the •	 Custom Stair tool. 
Do not require links with layer elevations or built-in visibility controls for other layers. •	
Have varying tread widths or shapes. •	
Require higher levels of 2D and/or 3D detail. •	
Comply with stringent, or a variety of drafting standards. •	
Change how 2D graphics are displayed at different scales. •	
Are easily shared—as complete configurations, or as sets of related property styles—with other drawings or users. •	
See Tips and Considerations below for more information. •	

Key features of the new Stair tool are summarized as follows: 
The •	 Stair tool creates a plug-in stair object. 
Additional Tool bar options let you pick up or apply stair attributes between stairs (select attributes and options in the  •	
Stair Settings dialog box’s Transfer tab), or update all stair plug-in objects in the current drawing file. 
There are significantly more display settings for precise control over 2D (or 2D only) and 3D appearance. •	
You can save a stair configuration as a plug-in symbol resource in the current document (or as a template in a library file),  •	
so you can share them with other files and users via importing/exporting, referencing, or placing them in default content files. 
You can also save, recall, and share sets of related property settings as •	 styles in the: Min./Max. Settings dialog box, 2D 
Graphics tab, Construction tab, Railings tab, and Graphics Attributes tab.
There are more tread shape options, and you can dynamically choose which tread(s) to reshape. You can optionally specify •	
different Detailed and Schematic view settings for 2D graphics in the: 2D Graphics tab, Construction tab, Railings tab, and 
Graphics Attributes tab. If you choose to use different view settings, either the detailed view or schematic view settings will  
be active, depending on the scale and the Hide Wall Components document preference setting. 
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Animation 
Click here to view an animation of these features. 

Access 
Building Shell tool set: Stair  

Process Overview 
The following simplified steps describe the basic workflow for creating a stair plug-in object with the new Stair tool.

Note: 	The new Stair tool features extensive controls and options for physical configuration, graphical display, and sharing data. 		
	 See all Tips and Considerations below for additional information, and refer to the online help system for fully detailed  
	 instructions and complete coverage for all options. 

From the Building Shell tool set, click 1.	 Stair . From the Tool bar: 
Click Insert •	 Stair  (if it’s not already active). 
Click •	 Preferences  to display the Stair Settings dialog box. 

Important: 	To accept parameter values, click in another field or press Tab (do not press Enter). At any time in steps 2 or 3, click Calculate to 			
		  incorporate the current settings, or click Previous Stair to revert them. Any preview image(s) in the active tab will update with the changes.

Select the General tab (if it’s not already active), and then: 2.	
Choose either a symbol or standard configuration in the General Configuration section. •	
Optionally click •	 Min./Max. Settings, then *specify limit values for tread depth, riser height, and step length (which you  

	 can adjust at any time). These limits define a geometric envelope in which the dimensions for unlocked stair parts may 		
	 automatically adjust to fit the overall height and length. 

Adjust General Settings and Preview preferences. •	
Specify applicable parameter values for General Geometry. Lock any values that you don’t want changed                 		 •	

	 during calculations. 
Select the Geometry tab, and then specify—and optionally lock—applicable parameter values for Basic Geometry and Detailed 3.	
Geometry (click treads to highlight or clear selections for oblique parameters—which can be positive or negative values). 
Select the 2D Graphics tab, and then for Detailed View and Schematic View as applicable, *specify options or values for      		 4.	
Stair Break Settings, Starting (Bottom) Tread Marker, Ending (Top) Tread Marker, and 2D Graphics Settings (click Stair Data   		
to specify standard and custom stair annotations, and control text display options in the Stair Data Settings dialog box). 
Select the Construction tab, and then for Detailed View and Schematic View as applicable, *specify options or values for 		 5.	
Construction Configuration and Construction Settings. 
Select the Railings tab, and then for Detailed View and Schematic View as applicable, *specify options or values for  			  6.	
Show Railings, Accept Settings for, Railing Height, Location Settings, Top Rail, Frame, Frame Bars, and Posts. 
Select the Graphic Attributes tab, and then for Detailed View and Schematic View as applicable, *specify options for  7.	
Graphic Attribute Settings (double-click an attribute to change its display properties). 
Click 8.	 OK to close the Stair Settings dialog box. 
Click once in the drawing area to specify the base point, and then click again to specify the rotation. After a brief pause,   		 9.	
the stair plug-in object is created. 

	 *If applicable, choose an existing style to automatically configure option settings and populate parameter field values. If  
	 you want to save a style after configuring the settings, click Save and specify a file name for a new style, or select an existing  
	 style to replace it. 

http://download2cf.nemetschek.net/www_movies/2010/New-Stair-Tool.mov
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Tips and Considerations 
Keep in mind the following tips and considerations when using the new Stair tool: 

Click the •	 Calculate button in the Stair Settings dialog box before you make substantial or experimental changes in case  
you need to revert them with the Previous Stair button. 
You cannot link the stair plug-in object’s overall height to layer elevations. •	
There are no built-in visibility controls for other layers. •	
To edit plug-in object stair settings, you can either double-click the stair object, or click •	 Settings in the Object Info palette  
or Properties dialog box, where only class, layer, and positional settings are displayed. 
Save sets of various properties styles and share them with other users to ensure compliance with your building code,  •	
drafting, and quality standards. You may find it helpful to use prefixes in style names to identify and manage related styles. 
You don’t have to save property styles when you initially create the stair. At any time, you can edit a selected stair obect  •	
and extract any or all styles. 

Enhanced Wall Joining 
Product: Fundamentals

New wall and component join improvements are summarized as follows: 
Walls can now be joined end-to-end (use •	 L Join Mode , or drag  
one wall’s endpoint grip and drop it on the other wall’s endpoint). 
You can now drag a wall segment beyond the walls it’s  •	
joined to or surrounded by. 
Round walls can now be Y-joined. •	
Wall components in round walls can now be joined. •	
All joins are now persistent after wall reshape operations. •	
One component in a wall can now be flagged as a core •	
component (in the new Core column in the Edit Wall 
Style’s Wall Definition tab). 
Core wall components can now auto-join. •	
Wall components of the same fill can now auto-join. •	
Wall caps can now use wall component line attributes •	
(click Edit Wall Attributes in the Edit Wall Style’s Wall 
Definition tab). 
Wall caps are now always flat; the Type drop-down list  •	
for caps (and the Round option) have been removed from 
the Object Info palette and all applicable dialog boxes. 
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Access 
Building Shell tool set: Wall Join  (or press Alt+J (Windows), Option+J (Mac)) (Architect only) Component Join   
(or press Alt+J (Windows), Option+J (Mac)) 

New Notes Manager Capabilities 
Product: Architect, Landmark, Spotlight, Machine Design 

Vectorworks 2010 includes the following improvements for callouts, keynote legends, and the Notes Manager: 
New bubble and leader styles for callouts (and new bubble options for keynotes) give you more control over appearance,  •	
while ensuring compliance with office graphic standards. 
You can now place callouts as keynotes, for user-definable key tags that are reflected in the keynote and legend.  •	
They will also associate with a legend on the same layer (as in previous versions) or any other legend in the document. 
Keynote legends now update dynamically. •	
You can now create multi-column (up to 4 columns) text for keynote legends. •	
Keynote Legends can now optionally display and sort the notes they contain by user-definable key tags. •	
You can now optionally auto-sort keynotes lists in the Notes Manager dialog box. •	

Animation 
Click here to view an animation of these features. 

Access 
Basic palette: Callout tool  (or press Alt+1 (Windows), Option+1 
(Mac)) Dims/Notes tool set: General Notes tool  

http://download2cf.nemetschek.net/www_movies/2010/Notes-Manager-Improvements.mov
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Improved Wall Hole Editing 
Product: Fundamentals

Vectorworks 2010 now displays temporary visibility cues in wall hole component editing mode for  
in-context editing of wall hole geometry. You can easily identify the instance of the symbol currently  
being edited by its normal display attributes; all other objects are grayed. 

Access 
To activate in-context editing of 3D wall hole geometry: Right-click a symbol instance and select  
Edit 3D Wall Hole Component from the context menu. 

Prevent Wall Insertion Option 
Product: Fundamentals

A new symbol insertion option lets you control whether symbols or  
plug in objects are inserted in walls. 

Access 
You can toggle the Insert in Walls option in the Insertion Options 
dialog box when you create a symbol: 
Menu: 	Modify > Create Symbol, then click Options. For an 	
	 existing symbol: Right-click the symbol in the Resource 	
	 Browser and select Edit. In the Edit Symbol dialog box, 	
	 select Insertion Options, and then click Edit. 



Vectorworks 2010 Version     53

Vectorworks 2010 Your Guide to What’s New

Improved Wall Hole Textures 
Product: Renderworks 

Renderworks 2010 now lets you assign textures to each side of the wall hole opening. 

Access 
You can specify texture settings for selected wall hole component geometry in the Assign Part drop-down list in the Object Info palette’s 
Render tab. For existing symbol instances: Right-click a symbol instance and select Edit 3D Wall Hole Component from the context 
menu. To edit the symbol definition in the Resource Browser: Right-click a symbol and select Edit from the context menu. Select the  
3D Wall Hole Component option and click Edit. 

Simple and Custom Stair 
Product: Fundamentals

The Vectorworks 2009 Fundamentals version of the Stair tool is now available in all products and has been renamed to Simple Stair.  
The Vectorworks 2009 Design Series Stair tool has been renamed to Custom Stair (for Design Series products, see also New Stair Tool). 

Access 
Building Shell tool set: Simple Stair  or Custom Stair  
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Place Column ID on Drawing 
Product: Architect 

A new option for column and pilaster objects lets you place the column ID on the drawing, in a class you specify. The column ID text: 
Attributes are controlled by Text menu commands. •	
Class defaults to None, but can be changed to any class. •	
Can be repositioned by clicking the control point to “pick up” the text, and then clicking again to specify the new location. •	

Access 
You can toggle the Display Column ID option, and change text class settings in the Object Info palette or Object Properties dialog box. 
Building Shell tool set: Column , Pilaster . Click Preferences  from the Tool bar. To change the class, click Get Finishes/
Classes, and then select another class from the Column ID Text drop-down list. 
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3D Structural Shapes 
Product: Architect, Landmark, Spotlight, Machine Design 

Vectorworks 2010 adds the following tools to create 3D structural shapes with profiles identical  
to those created by the corresponding 2D tools: 

Angle - 3D•	  
Bulb Flat - 3D•	  
Channel - 3D•	  
I-Beam - 3D•	   
Rectangular Tubing -•	  3D 
Round Tubing -•	  3D  
Square Tubing -•	  3D  
Tee -•	  3D  
Wide Flange - •	 3D 

Access 
Detailing tool set: (multiple tools) 

Tips and Considerations 
Keep in mind the following tips and considerations when using 3D structural shapes:

You can insert 3D structural shapes in any view, but like all 3D-only objects, the initial  •	
placement is constrained to a plane parallel to the X-Y plane. 
See also •	 New Properties Dialog for Structural Shapes. 

New Z Section Objects 
Product: Architect, Landmark, Spotlight, Machine Design 

Vectorworks 2010 adds two new tools to create 2D and 3D Metric and DIN series Z-section structural  
shapes. You create and modify the new Z-section objects in the same manner as the other structural  
shapes, which are all available as default content for structural components of compound objects  
such as columns and pilasters. 

Access 
Detailing tool set: Z-Section  or Z-Section - 3D  
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New Content 
Product: Architect 

Vectorworks Architect 2010 improves or adds many new resources and symbols, including: 
Updated Weather Shield door and window library •	
New skylights from Velux •	
Haddonstone and Bradstone water features •	
New fireplace fronts, mantels, and surrounds •	
New Audio/Video and Home Electronics Library •	

Access 
Vectorworks application folder]\Libraries folder and subfolders 
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Vectorworks Landmark 
Landmark 2010 includes new parking tools, enhances hardscape and landscape area objects, extends site modeling  
capabilities, improves usability, and adds or improves many symbols and resources. 

New and Improved Parking Tools 
Product: Landmark 

Landmark 2010 introduces two new tools that let you create intelligent and reportable parking space objects: 
Parking Along Path•	  tool  - Creates parking along path objects with head in or parallel parking spaces  
along straight           or curved paths. 
Parking Area•	  tool  - Creates parking area objects with a rectilinear array of parking spaces. 

For both of these parking objects: 
The built-in polyline tool lets you draw parking space paths or boundaries. •	
You specify the width, length, and starting number of all parking spaces. •	
You can toggle visibility of all parking space numbers. •	
You can directly modify the path or boundary by double-clicking the parking object to activate the •	 2D Reshape tool . 
You can access other context menu editing options by right-clicking the parking object. •	

For parking area objects: 
You can change the angle of the spaces and rows. •	
You can specify the access lane width (the open area between space rows). •	
You can toggle visibility of the perimeter and header stripe (the line between back-to-back spaces). •	
3D polygons are displayed in 3D views. You can apply textures in the Object Info palette’s Render tab. •	

Animation  
Click here to view an animation of these features. 

Access 
Site Planning tool set: Parking Along Path , or Parking Area  You can alternately create these objects  
with the Objects from Polyline command: 
Menu: Modify > Convert > Objects from Polyline 

http://download2cf.nemetschek.net/www_movies/2010/Parking-Tool.mov
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Tips and Considerations 
Keep in mind the following tips and considerations when using the new parking tools:

For parking along path objects, the parking space width is always the minimum width of the space. •	
For parking area objects, you can use other closed drawing objects with the object surface editing commands  •	
to add or remove areas (such as tree islands or handicap spaces) and the parking spaces adjust accordingly. 

New Hardscape Capabilities 
Product: Landmark 

Vectorworks Landmark 2010 includes the following improvements for Hardscape objects: 
Fills specified with the Joint Pattern drop-down list are now associative hatches (not individual line objects). This change •	
decreases file size, eliminates irrelevant snap points, and ensures all pattern rows will be hatched when the fill origin is moved. 
Default content textures are now displayed in the Hardscape dialog box’s Main Texture and Border Texture drop-down lists. •	
Paths for pathway hardscapes are now always “unclosed”. If you draw a closed shape for the path, one segment of the •	
hardscape will be omitted because pathways can’t connect to themselves. Also, pathway hardscapes created with offsets are 
now more reliable. 
Split and trim operations on hardscapes with holes now  work correctly. •	
Hardscape textures selected in the Hardscape Object •	
Settings dialog box (displayed by clicking Preferences ) 
prior to drawing the file’s first hardscape object are            
now persistent. 
The line on hardscape edges with hidden borders is now •	
also hidden, so you can join hardscapes together without a 
seam. This also applies to pathway and area hardscapes 
without borders. 

Animation 
Click here to view an animation of these features. 

Access 
Site Planning tool set: Hardscape  

http://download2cf.nemetschek.net/www_movies/2010/Hardscape-Capabilities.mov
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Tips and Considerations 
Keep in mind the following tips and considerations when using the new hardscape capabilities: 

Changing the hardscape’s line attributes (color, style, and weight) no longer changes the joint pattern hatching attributes.  •	
You must change the attributes of the hatch itself. 
Flagstone and paver fills use a default content hatch, which you can then modify or replace with one of the same name. •	

Improved Landscape Area Object 
Product: Landmark 

Landmark 2010 introduces new display options for landscape areas: 
Concave billow type - In the new Billow Type drop-down list, you can choose •	 Convex (as in Landmark 2009)  
or Concave (new) display for landscape areas with plant cloud border styles. 
3D Display•	  - This new drop-down list lets you control landscape area graphics for all views other than Top/Plan.  
You can choose between 2D Only (default - planar object outline), 3D Plants (any plants specified will be displayed),  
3D Poly (3D area), and Texture Bed (DTM site modifier). 

Note: 	If the 3D Plants option is selected and there are no plants 	
	 in the landscape area, a 3D locus will be displayed. 

Animation 
Click here to view an animation of these features. 

Access 
For new landscape areas, you can specify these options              
in the Landscape Area Preferences dialog box: 
Site Planning tool set: Landscape Area , and then                    
click Preferences . 

Note: The Landscape Area Preferences dialog box is automatically displayed after you draw the first landscape area in a file. 
	 For existing landscape areas: Select options in the Object Info palette, or double-click a landscape area and select Settings 
	 in the Edit Landscape Area dialog box. 

http://download2cf.nemetschek.net/www_movies/2010/3D-Graphics-for-Landscape-Area-Objects.mov
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DTM Triangulation Improvements 
Product: Architect, Landmark 

The new DTM triangulator module is more robust, reliable, and can now handle concave topography. 

Access 
Menu: Landmark > Create Site Model 

Improved DTM Site Border Editing 
Product: Architect, Landmark 

The following site model border improvements simplify the editing process while providing more shaping options: 
Site model borders are now polyline objects, which are compatible with an extensive variety of reshaping and editing  •	
tools. When you edit the site model border, the site model will be cropped or extended in both 2D and 3D views. 
The new •	 Edit Site Border context menu command provides direct access to the new site border editing mode. 
For clarity, the term “site border” replaces the term “hull” used in previous versions. •	

Access 
Right-click the DTM object and select Edit Site Border from the context menu. The site model border object (polyline) is selected        
in Top/Plan view with the 2D Reshape tool active. After editing, click Exit Site Border to terminate site border editing mode and 
incorporate the changes. 

Tips and Considerations 
Keep in mind the following tips and considerations when editing DTM site borders: 

If you reshape or otherwise extend the site model border, only the border with be extended (site model geometry will not         •	
be extended). 
If you can’t undo your site border edits, you can re-create the default site border and start over. To do this, activate the          •	
Edit Site Border command, and then select the site border and delete it. Click Exit Site Border, and then double-click the    
site model and toggle the Draw Site Border option off and on. A new default site border is created, which you can then edit. 
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New Plant Definition Options 
Product: Landmark 

Landmark 2010 now displays the Spread and Height values (from 
the Plant Data tab) next to the Plant Graphics Spread and Height 
fields in the Definition tab of the Edit Plant Definition dialog box. 
This makes it easier to match or offset values because you can 
now see the plant data spread and height on the same tab where 
you specify graphical properties. 

Access 
Site Planning tool set: Place Plant , click Preferences  in 
the Tool bar, select a plant and click Edit Definition, then select 
the Definition tab. For existing instances of plant objects: You can 
either right-click a plant and select Edit from the context menu, or 
double-click a plant to display the Edit Plant dialog box. You can 
then choose the Definition option and click OK to display the Edit 
Plant Definition dialog box. 

New Grade Calculator 
Product: Landmark 

The new Grade Calculator  provides two basic methods for 
calculating the difference in elevation and grade percentage 
bewteen two points you specify: 

Manually•	  - You choose which one of the three slope 
parameters (% Grade, Delta Z, and Length) is automatically 
calculated by values you enter for the other two. 
Automatically•	  - You can extract all three three slope 
parameters by selecting points on an existing or proposed 
DTM. You can optionally insert the calculation results into 
your drawing by selecting text labels for any or all of the 
slope parameters. 

Access 
Site Planning tool set: Grade Calculator . Click two points to 
draw a line and display the Grade Calculator dialog box. You can 
then optionally modify and recalculate grade parameters, specify 
DTM options, and choose which text labels will be displayed. 
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Tips and Considerations 
Keep in mind the following tips and considerations when using the new Grade Calculator: 

The length parameter is initially defined by the length of the line. If necessary, you can change the length, which moves the •	
endpoint accordingly. 
If a DTM is present and the DTM options are grayed out, update the DTM to enable them. •	
Click •	 Cancel when finished if you only want to temporarily view the results. 
When you click •	 OK, a group is created that contains any selected text labels and a line with an arrow end marker. This line is 
always drawn - even when no text labels are selected for display. 
You cannot re-activate the •	 Grade Calculator from the calculation results once they’re placed on the drawing. If you want to 
change the values, delete the results, activate the Grade Calculator tool, and perform another calculation operation. 

 
Use Site Modifiers on Visible Layers Only 
Product: Architect, Landmark 

A new option in Vectorworks Architect and Landmark 2010 lets you limit existing and proposed site modifiers to visible layers only. This 
lets you store multiple configurations of site modifiers on different layers and recall any combination of them using layer visibility 
controls in saved views. 

Access 
You can select the Visible Layers Only option from the Use Site 
Modifiers on drop-down list in the Create Site Model or Site 
Model Settings dialog boxes: 
Menu (new site model): Landmark > Create Site Model. To 
display the Site Model Settings dialog box (existing site model): 
double-click a site model; or right-click a site model and select 
Edit from the context menu; or select a site model and click Site 
Model Settings in the Object Info palette. 

Tips and Considerations 
Keep in mind the following tips and considerations when using 
site modifiers on visible layers only: 

You must update the site model to incorporate changes •	
after changing layer visibilities. 
You may find it helpful to create a layer naming scheme that facilitates layer visibility control and ensures that all related objects •	
(for example: texture beds, plants, and constructed elements) on different layers are included when you switch configurations. 
If you use worksheets to extract and tabulate landscaping database records, be sure to limit the criteria to the active layer(s),      •	
or else data from all layers will be extracted. 
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New Stake Object Coordinates 
Product: Landmark 

Landmark 2010 adds a new coordinate point label option to the stake object. The coordinates are displayed as northings and eastings 
(distances from the drawing’s origin, prefixed with the direction N,W,S, or E), which update if you reset the origin or move the stake 
object. As with other stake object labels, you can reposition the label by clicking the control point to “pick up” the label, and then clicking 
again to specify the new location. There are three new options for displaying coordinate point labels for stake objects: 

The •	 Coordinate Point option in the Label Reference drop-down list. 
The Coordinate Units drop-down list with 3 options: •	 Document Units; Feet; or Meters. 
Display Leader Line•	  option - When enabled, a line is drawn between both coordinates to the center of the stake object, with a 
vertex at the text control point. 

Note: 	The Circle Style option is recommended for coordinate 	
	 points, but you can choose any style. 

Access 
For new stake objects, you can adjust coordinate point                   
label settings in the Object Properties dialog box: 
Site Planning tool set: Stake Object , and then                               
click Preferences .       

Note: 	The Object Properties dialog box is automatically displayed 
after you draw the first stake object in a file. For existing stake 
objects, you can adjust coordinate point label settings in the 
Object Info palette. 
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New Landmark Schedule Command 
Product: Landmark 

The new Choose Schedule dialog box lets you create the following default landscape-specific reports or schedules: 
Irrigation Head Schedule •	
Irrigation Line Schedule •	
Plant List-Basic •	
Plant List-Colors •	
Plant List-Costing •	
Plant List-Simple •	

Access 
Menu: Tools > Reports > Choose Schedule. Select a default schedule worksheet in the Choose Schedule dialog box. 

New Content 
Product: Landmark 

Vectorworks Landmark 2010 includes the following new or improved resources and symbols: 
Improved default plants include 3D representation (Renderworks required) •	
Improved Plant Database with new images and plant data •	
from Monrovia Nurseries 
New rock objects •	
Haddonstone and Bradstone water features •	
New hardscape paver resources in 2D and 3D •	
Improved sitework trees •	

Access 
[Vectorworks application folder]\Libraries folder and subfolders 
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Vectorworks Spotlight  

Vectorworks Spotlight 2010 accelerates event planning tasks, introduces new video screen objects, improves usability, and adds many 
new symbols and resources. 

New Event Planning Suite 
Product: Spotlight 

Vectorworks Spotlight 2010 introduces new event-planning tools, commands, and objects that simplify facility layout tasks and facilitate 
the process of creating documentation for events (such as: banquets; ceremonies, off-site meetings/presentations; training sessions; 
and show exhibits). The new Event Planning menu lets you create the following objects: 

Room•	  - Converts a selected drawing object (rectangle, ellipse, polygon, arc, circle, rounded rectangle, or polyline) to walls and 
a floor from settings you specify in the Create Room dialog box. 
Stage•	  - Converts a selected drawing object (rectangle, ellipse, polygon, arc, circle, rounded rectangle, or polyline) to a stage 
object from settings you specify in the Create Stage dialog box.
Stair•	  - Creates a simple stair object from settings you specify in the Create Stair dialog box. To insert the simple stair object, 
click OK, then click once to specify the insertion point, and then click again to specify rotation. You can then adjust other 
settings in the Object Info palette. 
Lectern•	  - Creates a 2D/3D lectern symbol from settings you specify in the Create Lectern dialog box: Choose a preconfigured 
lectern, and then you can optionally specifiy custom attribute settings. To insert the lectern symbol, click OK, then click once to 
specify the insertion point, and then click again to specify rotation. 
Screen•	  - Inserts a preconfigured television or video screen object that you select in the Create Screen dialog box. To insert the 
television or video screen object, click OK, then click once to specify the insertion point, and then click again to specify rotation. 
You can then adjust other settings in the Object Info palette. 
Event Seating•	  - Converts a selected drawing object (rectangle, ellipse, polygon, arc, circle, rounded rectangle, or polyline) to a 
seating layout with tables and/or chairs from settings you specify in the Create Event Seating dialog box, and then automatically 
generates or updates the Seating Count worksheet to tabulate the quantities. 
Views•	  - Creates two sheet layers with corresponding viewports; one for a plan view and one for an isometric view with   
OpenGL rendering. 

Animation 
Click here to view an animation of these features. 

Access 
Menu: 	Event Planning > Create Room, Create Stage, Create Stair, 		
	 Create Lectern, Create Screen, Create Event Seating, Create Views 

http://download2cf.nemetschek.net/www_movies/2010/Event-Room-Layout.mov
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New Video Screen Objects 
Product: Spotlight 

Vectorworks Spotlight 2010 adds three new tools to create video displays in your designs. The new television, video screen, and 
blended screen objects provide accurate 2D and 3D representations for placement, image size, and viewing area. With Renderworks, 
you can optionally display an image on the screen for realistic effect. 

Television •	 - Creates flat panel TVs in standard sizes 
and mounting configurations or CRTs in standard sizes.                 
Use the CRT Curved type to represent computer moni-
tors. 
Video Screen•	   - Creates LED or projection screens in 
standard sizes with an optional front or rear projector. 
Blended Screen •	  - Creates large-format projection 
screens from image width and height dimensions you 
specify, with optional front or rear projectors. 

Animation 
Click here to view an animation of these features. 

Access 
Spotlight tool set: Television , Video Screen , or  Blended Screen . Click once to specify the insertion point, then click 
again to specify the rotation. You can then adjust settings the Object Properties dialog box (to set defaults for the first object of each 
type in the file), or Object Info palette for existing objects. 

http://download2cf.nemetschek.net/www_movies/2010/Video-Screen-Objects.mov
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New Seating Layout Capabilities 
Product: Spotlight 

Vectorworks Spotlight 2010 includes the following seating layout improvements: 
The new •	 Offset Alternate Row option in the Object Info  
palette and Properties dialog box staggers seating by half  
the distance of the Seat Spacing setting. 
The calculation for the initial row and seat spacing is now •	
based on the size of the chosen symbol. 
The Seating Count schedule displays and counts nested •	
symbols, such as tables and chairs. 

Access 
Menu: AEC > Create Seating Layout 

Double-Click Insertion 
Product: Spotlight 

Spotlight 2010 now lets you double-click lighting instrument or accessory symbols from the Resource Browser to automatically activate 
both the symbol and its associated insertion tool. 

Access 
From the Resource Browser, double-click an instrument or accessory. 
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Improved Lighting Device Color Support 
Product: Spotlight 

You can now specify lighting instrument color by any one of the following methods: 
RGB values separated by commas (such as 191, 49, 26); values must be between 0 and 255 •	
Web hex values prefixed by the pound sign (such as #003366) •	
Manufacturer color codes, by manufacturer name or abbreviation and color number (such as Gam 650, G 650, or G650) •	

Access 
You can specify lighting instrument color in the Lighting Device dialog box for one or more selected lighting instruments: 
From the Object Info palette or context menu, select Edit ,or double-click a single instrument. 

New Lighting Device Types 
Product: Spotlight 

Spotlight 2010 adds Device, Practical, SFX, Power and Other values  
to the Device Type drop-down list for lighting devices. These new device types: 

Eliminate data loss during data exchanges with Lightwright  •	
(previous versions automatically converted these values into  
the default Light value, resulting in data loss). 
Are treated as “Light” device types, for compatibility with •	
existing documents. 
Are now evaluated in •	 Key to Instrumentation reports. 

Access 
You can select the new options from the Lighting Device         
drop-down list in the Object Info palette. 
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Create Universal Spotlight Object Libraries 
Product: Spotlight 

To save file space, Vectorworks Spotlight 2010 now uses the same library files for imperial and metric applications. The new “Light Info 
Record M” database record is now attached to all library objects that can be converted to lighting devices. If the document units are: 

Metric - Frame size and weight settings are controlled by the Light Info Record M database record. •	
Not metric - Frame size and weight settings are controlled by the Light Info Record database record. •	

Note: 	To allow migration of existing documents without the Light Info Record M database record, default data from the 
	 Light Info Record database record is used. 

Access 
[Vectorworks application folder]\Libraries folder and subfolders 

New Content 
Product: Spotlight 

Vectorworks Spotlight 2010 includes the following new or improved resources and symbols: 
Altman •	
Clay Paky•	
ETC•	
High End•	
Stron/Xenotec•	
Vari-Lite•	

New Lighting & Truss Catalogs from: 
ADB Lighting•	
DTS- Lighting•	
JB Lighting•	
Eurotruss•	

New and Improved Gobo Catalogs from: 
Apollo •	
GAM •	
Rosco •	
GOBOLand (New)•	
GoboMan (New)•	
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Other new content: 
New Fireplace Fronts, Mantels, and Surrounds •	
New Water Features•	

Access 
[Vectorworks application folder]\Libraries folder and subfolders 
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Vectorworks Machine Design 
Vectorworks Machine Design 2010 introduces more fastener object types, improves analytical functions with simple beams,  
and lets you configure pipe threads for shafts. 

New Sheet Metal Screws 
Product: Architect, Landmark, Spotlight, Machine Design 

The new Sheet Metal Screw tool  lets you create 2D and 3D sheet metal screws in either Inch or Metric series. You specify  
the view, series, head and slot types, and length. After creating the sheet metal screw object, you can change the nominal size  
and other options in the Object Info palette. You can optionally display the threads and centerline. 

Tip: You can also use the Create Similar Object feature to duplicate existing lag screws in designs with multiple sizes. 

Access 
Detailing tool set: Sheet Metal Screw  or Sheet Metal Screw - 3D  

New Lag Screws 
Product: Architect, Landmark, Spotlight, Machine Design 

The new Lag Screw tool  lets you create 2D and 3D lag screws in either Inch or Metric series. You specify the view, series,  
and length, and then after creating the lag screw object, you can change the nominal size and other options in the Object Info  
palette. You can optionally display the threads and centerline. 

Tip: You can also use the Create Similar Object feature to duplicate existing lag screws in designs with multiple sizes. 
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Access 
Detailing tool set: Lag Screw  or Lag Screw - 3D  

New Carriage Bolt Objects 
Product: Architect, Landmark, Spotlight, Machine Design 

The new Carriage Bolt tool  lets you create 2D and 3D carriage bolts in either Inch or Metric series. You specify the view, series, 
length, and thread style and then after creating the carriage bolt object, you can change the nominal size, bolt type, and other options 
in the Object Info palette. You can optionally use standard length increments, and display the centerline. 

Tip: You can also use the Create Similar Object feature to duplicate existing carriage bolts in designs with multiple sizes. 

Access 
Detailing tool set: Carriage Bolt  or Carriage Bolt - 3D 
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New Simple Beam Properties 
Product: Machine Design 

The new Use Properties of Standard Shapes option in the Configure Beam dialog box lets you populate  
fields in the Beam Properties section with data from standard structural shapes (default content). 

Access 
Menu: Machine Design > Simple Beam (or press Ctrl+Shift+B (Windows), Cmd+Shift+B (Mac)) 

Improved Simple Beam Calculator 
Product: Architect, Landmark, Spotlight, Machine Design 

Abbreviated field titles on the Simple Beam Calculator dialog box 
have been replaced with more descriptive titles. Also, the new 
Use Properties of Standard Shapes option lets you populate 
fields in the Beam Properties section with data from standard 
structural shapes (default content). 

Access 
Menu: 	AEC > Framing > Simple Beam Calculator 
	 Landmark > AEC > Simple Beam Calculator
	 AEC > Simple Beam Calculator
	 Machine Design > Simple Beam Calculator 
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Improved Shaft Tool 
Product: Machine Design 

You can now add the following pipe inch and metric threads to 2D and 3D shafts: 
American National Standard Taper Pipe Threads (NPT) •	
American National Standard Straight Pipe Threads (NPS) •	
British Standard Taper Pipe Threads (BSPT) •	
British Standard Straight Pipe Threads (BSPS) •	

You can also specify whether threads taper to the right or left for NPT and BSPT threads. 

Access 
You can configure pipe threads for shafts in the Shaft Configuration dialog box: 
Machine Components tool set: Shaft  or Shaft - 3D . Click Preferences  from the Tool bar, and then click Properties in        
the Object Properties dialog box. For existing shafts, double-click the shaft object, or click Configuration in the Object Info palette. 
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Renderworks  

Renderworks 2010 includes new texturing options, better texture mapping controls, new HDRI backgrounds, and introduces  
the new VBvisual Plant tool. 

New Decal Texturing 
Product: Renderworks 

Renderworks 2010 introduces decals, which are masked, image-based textures that you place on top of an existing base texture. 
Some examples of the many uses for decals include: 

Labeling •	
Signage •	
Branding and logos •	
Framed wall decorations (such as posters,  •	
paintings, or photographs) 
Substitutions for complex 3D geometry •	
 in small-scale renderings 
Special effects with multiple layered textures (such as •	
creating the effect of depth with masked or transparent 
textures slightly offset from the base or other decals) 
Realistic effects with multiple layered textures (such as •	
wainscoting on a wall, or patterns on fabric) 
Creating the effect of “masking” rectangular or                •	
image-defined areas of the existing base texture (such     
as an unfinished wall area, or a texture fade-out effect) 

Animation 
Click here to view an animation of these features. 

Access 
Select a textured 3D object, then click Add Decal from the Render tab of the Object Info palette. 

Process Overview 
The following steps describe the general process for creating new decal texturing: 

Note: See all Tips and Considerations below before continuing. 

Apply a texture (either planar, spherical, or cylindrical mapping) to the 3D object that you want to add a decal to. 1.	
From the View bar, select 2.	 Fast Renderworks from the Current Render Mode drop-down list (if it’s not already active). 
Select the textured 3D object, and then from the Render tab of the Object Info palette: 3.	

If applicable, select the part where the decal will be placed from the Part drop-down list. •	
Click •	 Add Decal. 

http://download2cf.nemetschek.net/www_movies/2010/Decal-Textures.mov
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If the decal texture consists of an imported or reused image, the Decal Options dialog box opens, if you’re creating: 4.	
A rectangular mask decal, proceed to step 7. •	
An image mask, click •	 Choose Image, and then either import a new image, or select an existing image  

	 (including the current image), and then click OK to open the Create Mask dialog box. 
If you want the source for the mask to be: 5.	

Grayscale Pixels and Alpha Channel, click •	 OK. Proceed to Step 7. 
Transparent, select •	 Transparent Color and then select the desired mask properties and click OK. 

Click 6.	 OK to return to the Decal Options dialog box. 
Click 7.	 OK to create the: 

Decal texture, which is added to the Resource Browser. •	
Decal, which is placed by default on the bottom corner of the selected object, and listed in the Object Info  •	

	 palette’s Part drop-down list. 
If necessary, adjust the decal’s: 8.	

Position, scale, and rotation with the •	 Attribute Mapping tool   in 2D Mapping Mode. 
Texture properties from the Resource Browser. •	

Tips and Considerations 
Keep in mind the following tips and considerations when using decal textures: 

Decals are listed (along with their texture) in the the Render tab’s Part drop-down list of the Object Info palette. •	
You can place multiple decals on the same 3D object. Use the •	 Move Up or Move Down buttons on the Object Info  
palette’s render tab to change the stacking order. 
Decal textures are resources (the same as any other texture), so you can share them with other files and users  •	
via importing/exporting, referencing, or placing them in default content files. 
Decals are only displayed in Renderworks rendering modes. •	
Decal textures are independent of the base texture’s appearance. By default, decal textures only repeat once horizontally  •	
and vertically, with matte reflectivity and no bump or other material options. However, you can edit these and other texture 
properties from the Resource Browser to achieve any combination of color, reflectivity, transparency, and bump shaders. 

New Blur Reflectivity Shaders 
Product: Renderworks 

A new option in Renderworks 2010 lets you create a blur effect for simple glass and mirror reflectivity shaders. 

Animation 
Click here to view an animation of these features. 

http://download2cf.nemetschek.net/www_movies/2010/Blur-Reflectivity-Shaders.mov
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Access 
You can adjust the Blur Factor slider control in the Edit Glass, 
Simple Shader and Edit Mirror Shader dialog boxes:                          
Open the Edit Textures dialog box and select Glass, Simple or 
Mirror from the Reflectivity drop-down list, and then click Edit. 
Resource Browser menu (or right-click Resource Browser 
background): New Resource > RenderWorks Texture. You can 
control blur appearance quality and rendering speed for  Custom 
RenderWorks and Custom RenderWorks rendering modes with the 
Blur Quality drop-down list in the Custom Renderworks Options      
and Custom Radiosity Options dialog boxes: 

View bar: 	Current Render Mode > Options For Other Rendering 	
	 Modes > Custom RenderWorks Options or Custom 	
	 RenderWorks Options, then select Texturing. 
	 Current Render Mode > Custom RenderWorks 	
	 Options or Custom Radiosity Options (when either rendering mode is active) 
Menu: 	 View > Rendering > Custom RenderWorks Options or Custom Radiosity Options 

Improved Texture Mapping Controls 
Product: Renderworks 

Renderworks 2010 eliminates the Edit Mapping dialog box, adds a new Reset to Default Mapping button to the Object Info palette’s 
Render tab, and enhances both 2D and 3D texture mapping with the following improvements and new interactive controls for the 
Attribute Mapping tool : 

When this tool is active, the Object Info palette now only displays relevant controls on the Texture tab. •	
For 2D and 3D repeating textures, you can now toggle texture repetition with the new •	 Non-Repeating  and                     
Original Repeat  modes. 
If texture mapping parameters become uneditable, a new alert dialog box provides an option to automatically adjust them to •	
allow editing.
 Snapping with SmartCursor cues is now supported for all control points during all interactive operations. •	
You can now use either •	 2D Mapping Mode  or 3D Mapping Mode  to map textures on 3D objects. When you          
adjust mapping of 2D objects with associative hatches, the tool defaults to 2D Mapping Mode, and no options are displayed    
in the Tool bar. 

3D Mapping Mode  new features are summarized as follows: 
Texture space widget•	  - Provides dynamic controls—with full 3D snapping compatibility—for manipulating the position (drag the 
blue diamond handle at the origin) and rotation (click and drag the colored round axis handles) of the edited object’s 3D texture 
space (which determines the texture image’s projection). 
Set texture to face•	  - You can now click to locate the texture image on a surface (planar mapping type only). To do this, move 
the cursor away from the widget. When the hand cursor appears, click the same face or another face to reposition the texture. 
Texture frame imaging•	  - A lined frame now delineates the first texture repetition on the plane, sphere, or cylinder (set by map 
type). 
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3D Constrained Mode•	   - Limits texture space tilting to 
the current plane. 
3D Unconstrained Mode•	   - Allows texture space tilting 
around all axes. 

Animation 
Click here  to view an animation of these features. 

Access 
Basic palette or Visualization tool set: Attribute Mapping tool  
(or press Shift+A). You can either select the textured object first 
and then activate the Attribute Mapping tool, or select the 
textured object after you activate the tool. 

Tips and Considerations 
Keep in mind the following tips and considerations when using the new texture mapping controls: 

If you lose or can’t see the texture on the object during texture mapping manipulations, click the •	 Reset to Default Mapping 
button on the Object Info palette’s Render tab. Note that in some cases, you may then need to change the Map Type, and/or 
enable the Auto-Align Planar Mapping option. 
Hold down the Ctrl key (Windows) or Cmd key (Mac) during dynamic 2D resizing or rotating operations to resize or rotate from •	
the center of the texture frame. 
For easier (and faster display performance when) mapping of a repeating texture, enable •	 Non-Repeating Mode  to see a 
single repetition of the texture. When finished, enable Original Repeat Mode  to restore the pattern and verify the effect. 

New Content 
Product: Renderworks 

Vectorworks Renderworks 2010 adds new HDRI Backgrounds  
including exterior, interior, and studio backgrounds. 

Access 
[Vectorworks application folder]\Libraries folder and subfolders 

http://download2cf.nemetschek.net/www_movies/2010/Improved-Texture-Mapping.mov
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New VBvisual Plant Tool 
Product: Renderworks 

Renderworks 2010 adds the new VBvisual Plant  tool, and includes three sample VBvisual plants featuring top quality 2D and 3D 
display properties. VBvisual plant objects are hybrid symbols with 2D bitmap graphics and 3D “polygon cloud” construction so they: 

Look realistic in Top/Plan view and from any other viewing angle •	
Render relatively quickly •	
Minimally increase file size •	

Access 
Visualization tool set: VBvisual Plant . Select a plant from the VBvisual Plant drop-down list in the Tool bar to activate it. When 
the VBvisual Plant tool is active, one instance of the active plant will be inserted each time you click in the drawing area. The first  
time you place a VBvisual Plant object in the drawing, its symbol definition and texture(s) are added to the appropriate sections of the 
Resource Browser. 

Note: 	If you select More Plants from the VBvisual Plant drop-down list, you will be directed to the Vbvisual website, 
	 where you can purchase additional plants. 

Additional Training Materials 
Product: All 

Click the following links for more information on additional training materials to help you maximize productivity. 
Free Resource•	 s 
Vectorworks Learning Serie•	 s  
Architect Learning Serie•	 s 
Spotlight Learning Serie•	 s 
Landmark Learning Serie•	 s  
Renderworks Training C•	 D  
Training Guide•	 s  

Access 
Web site 
Call 410-290-5114 

http://www.nemetschek.net/training/free_resource.php
http://www.nemetschek.net/training/VW_LSeries.php
http://www.nemetschek.net/training/A_LSeries.php
http://www.nemetschek.net/training/S_LSeries.php
http://www.nemetschek.net/training/L_LSeries.php
http://www.nemetschek.net/training/R_LSeries.php
http://www.nemetschek.net/training/guides.php
http://www.nemetschek.net/training/index.php
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